Deep Freeze compatible with Windows XP Service Pack 2

Deep Freeze has been completely tested with and is compatible with Windows XP Service Pack 2. Workstations require no configuration changes. The Deep Freeze Enterprise Console needs to be unblocked in the Windows Firewall and all of your workstations will be displayed, just like before. For more information visit our Content Library.