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Introduction
Deep Freeze provides network administrators with a simple and 100 percent successful method of 
maintaining desktop systems and reduces software technical support to an absolute minimum. 
Completely invulnerable to hacking, Deep Freeze instantly protects and preserves original computer 
configurations. No matter what changes a user makes to a workstation, simply restart to eradicate all 
changes and reset the computer to its original state. Computing environments are easier to manage and 
maintain, and expensive computer assets are kept running at 100 percent capacity. The result is a truly 
protected and parallel network, completely free of harmful viruses and unwanted programs.

Who	should	use	this	document?

This document is intended for anyone who wants to use Deep Freeze in an Altiris environment. It 
explains how to:

Install the Altiris agent remotely

Install and upgrade the Configuration Administrator

Install and Uninstall Deep Freeze Workstation files and Seeds

Install and use Deep Freeze Command Line Control (DFC) to manage workstations both manually 
and as an Altiris job

To use this document, you should: 

Have a working knowledge of Altiris Deployment Console

Be familiar with creating Altiris jobs 

This document assumes that all the components of your Altiris environment are installed, configured, 
and operating correctly. The examples are based on Altiris Deployment Console version 6.0 (build 
206).

Installing	the	Altiris	Remote	Agent
Before you can install and manage Deep Freeze remotely, you must install the Altiris Remote Agent on 
the workstations (Altiris calls these clients) where you want to install Deep Freeze.

This following procedure is our recommended method for installing the Altiris Remote Agent. For 
more information on this and other methods for installing the remote Agent, see the Altiris Deployment 
Console documentation. 

To install the Remote Agent on client computers, you need an account with local user rights. You only 
need to use this account when installing Remote Agent, so either use your domain administrator or a 
domain account with local user rights. 

To	install	the	Altiris	Remote	Agent:

1. Confirm that your account has local user rights (admin$ Share), by browsing to: 
\\<hostname>\admin$ and replacing <hostname> with the name of the workstation on 
which you want to install the Remote Agent. If you can access this share you have sufficient 
rights.
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2. In the Altiris Deployment Console, from the Tools menu, select Remote Agent Installer. Follow 
the instructions then select the workstation(s) where you want the Remote Agent installed.  

3. Click Finish..

Once you have installed the Remote Agent, you can install Deep Freeze software on the workstations 
as long as you remain connected with those workstations.
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Installing	the	Deep	Freeze	Configuration	Administrator

The Deep Freeze Configuration Administrator is the component of the Deep Freeze installation that 
allows you to install workstation files, Workstation Seeds, and create the Enterprise Console. 

The Configuration Administrator should only be deployed to workstations that will require the 
administrative portion of the software installed.  

The following procedure uses a Customization Code. Keep this code secure as any user who obtains 
the Customization Code can bypass installed copies of Deep Freeze.

To	Create	an	Altiris	Job	for	Installing	the	Deep	Freeze	Configuration	Administrator:

1. In the Altiris Deployment Console, from the File menu, select New>Job Wizard. 
2. In the Manage Your Computers dialog box, select Deploy software packages. 
3. In the Name this job box, type a job name and click Next.
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4. In the Job Conditions dialog box, accept the defaults and click Next.
5. In the RapidInstall and PC Transplant Packages dialog box, click Add and browse to and 

select the Deep Freeze Configuration Administrator install file.
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6. Click Options.

7. Type the command /update=<customization code> c:\dflog.txt, where 
<customization code> is a ten-digit encrypted code that you assign, and Altiris applies to 
the Deep Freeze installation, and click OK.

To	Run	the	Altiris	Job	for	Installing	the	Deep	Freeze	Configuration	Administrator:

1. Drag and drop the created job on the machine where you want to install the Deep Freeze 
Configuration Administrator. .

2. Schedule the job to Run Immediately.

A warning message appears indicating the file is not a valid RapidInstall or PC Transplant 
package.

3. Click Yes.

Altiris installs the Configuration Administrator on the client computer.
4. Browse to C:\Program Files\Faronics\Deep Freeze 6 Enterprise and double-click DFadmin6 to 

start the Configuration Administrator.
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Upgrading	the	Deep	Freeze	Configuration	Administrator

To upgrade the Deep Freeze Configuration Administrator to a more recent version, replace the 
installation file on the network share with the updated DF6Ent.EXE application and complete the 
previous procedure. 

Installing	the	Deep	Freeze	Workstation	installation	file	and		
Workstation	Seed	File

The Deep Freeze workstation install files and Workstation Seed files are the workstation level 
components of Deep Freeze  that need to be installed on all workstations that protected by Deep 
Freeze. The following procedure assumes that you already have created the Deep Freeze installation file 
or the Seed file and are ready to install.  

You do not need to install both the workstation installation file and the Workstation Seed. The 
workstation installation file contains a full copy of the Workstation Seed and is installed when you run 
the full workstation installation. The Workstation Seed should only be installed if you want to use the 
Deep Freeze Enterprise Console to push the workstation installation file to workstations rather than 
using Altiris.

To	Install	the	Workstation	Installation	or	Seed	Files:

1. Copy the Seed or the workstation installation file to a share on the network that the 
workstation can access. 

2. In the Altiris Deployment Console, from the File menu, select New>Job Wizard.
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3. In the Manage Your Computers dialog box, select Deploy software packages.

4. In the Name this job box, type a job name and click Next.
5. In the Job Conditions dialog box, accept the defaults and click Next.
6. In the RapidInstall and PC Transplant Packages dialog box, click Add and browse to and 

select the workstation or Seed install file.
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7. Click Options.
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8. Type the command /install and click OK. This lets Deep Freeze install without your 
intervention, or “silently.”
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9. Select the workstation(s) where you want the package installed, and click Next.
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10. In the Schedule Job dialog box, select Run this job immediately, and click Finish.

Altiris will install Deep Freeze and Deep Freeze will start in a Frozen state.

Uninstalling	Deep	Freeze

To uninstall Deep Freeze, simply thaw or disable Deep Freeze on the chosen workstation(s) using 
the boot Thawed command discussed on the following pages of this document. Then complete the 
previous installation process.
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Using	Deep	Freeze	Command	Line	Control	to	Control	Deep	
Freeze

The Deep Freeze Command Line Control (DFC) offers network administrators increased flexibility 
in managing Deep Freeze workstations. DFC works in combination with third-party enterprise 
management tools and/or central management update workstations on the fly and on demand. For 
more information on the DFC command, see the Deep Freeze Enterprise User Guide.

Installing	Deep	Freeze	Command	Line	Control	on	workstations

You can control an installed copy of Deep Freeze using Altiris Deployment Console and Deep Freeze 
Command Line Control (DFC). The DFC.EXE application is installed by default in the C:\Program 
Files\Faronics\Deep Freeze 6 Enterprise folder. You must copy it to workstations or run it by Altiris 
from a publicly accessible network share on the local machine to control the status of the systems.

To	install	DFC	on	workstations:

1. Copy the DFC.exe file to a share on the network that the workstation can access.

2. In the Altiris Deployment Console, select the workstation(s) where you want the DFC 
copied,  right-click, and select Copy File to.
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3. In the Copy File dialog box, select Copy File and in the Source path dialog box, select the 
DFC.exe file you want copied to the workstation, and in the Destination path box, type 
the location you want it located on the workstation. We recommend you put it in the C:\
Windows\System32  folder since this location is already mapped.

4. Click OK 

The DFC.exe file is transferred to the workstation. Once file is transferred you can start 
using DFC command on the workstations.

Controlling	Deep	Freeze	with	DFC	command

The following procedure provides an example of controlling a workstation using the DFC command, 
by thawing a workstation. 

You can thaw a workstation in three ways:

From the Deep Freeze Console, select the machine in the workstations pane, and select Reboot 
Thawed. 

On the local machine, shift+double-click the Deep Freeze icon, enter the Customization Code, 
and thaw the machine.

Using the DFC command remotely, as described in the following procedure.

1.

2.

3.
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You can control Deep Freeze with the DFC command using the Altiris Deployment Console manually 
or by creating an Altiris job. 

To	manually	use	the	DFC	command	to	control	Deep	Freeze:

1. In the Altiris Deployment Console, right-click the workstation where you want the DFC to 
run and select Execute.

2 In the Execute a Remote Command dialog box, in the Command to execute box, type the 
command line you want to execute; for example, to thaw a machine type dfc <password> 
/bootthawed, where <password> is the password you have set in the Deep Freeze 
Configuration Administrator, and click OK. Include a space between the password and the 
switch (/).
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Here are some example DFC command line switches:

/THAWNEXTBOOX - Sets the computer to reboot into a thawed state during the next reboot. This 
command only works on Frozen workstations.

/FREEZENEXTBOOT - Sets the computer to reboot into a frozen state during the next reboot. This 
command only works on Thawed workstations.

/THAWLOCKNEXTBOOT - Sets the workstation to restart into a Thawed state with the keyboard and 
mouse locked during the next reboot.

Refer to the Deep Freeze Enterprise User Guide for other possible command line switches.

Please note that the use of hte /BOOTTHAWED /BOOTFROZEN, and /BOOTTHAWEDNOINPUT 
perform a reboot immediately upon being run. This immedate reboot prevents the Altiris 
Deployment Server from being able to realise that the command has run succesfully. To ensure 
that the command is properly run the use of the /THAWNEXTBOOT, /FREEZENEXTBOOT, and 
/THAWLOCKNEXTBOOT commands is reccomended. 

Using	DFC	in	an	Altiris	job

The following procedure automates the process of using the DFC command to control Deep Freeze so 
that you can run the job anytime.

To	Create	a	DFC	Altiris	Job	that	Uses	DFC:

1. In the Altiris Deployment Console, right-click the Jobs pane and select New Job.

2. In the Job Properties dialog box, in the Name box, type a name (Description is optional) 
and click Add.
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3. Select Run Script.

4. In the Script Information dialog box, select Run this script and type the script you want to run.
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5. In the Choose the script operating system area, select Windows..

6. Click Next.

7. In the Script Information dialog box, accept the defaults and click Next.
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8. In the Return Codes dialog box, accept the defaults and click Finish.
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9. In the Job Properties dialog box, click OK.

The Altiris job is created. 

You can now drag and drop the job to the workstation of your choice, and you can schedule the job to 
run immediately or at some future date.
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