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Introduction
This document provides a step-by-step overview of the process to update an installation of Deep Freeze 
Enterprise and Deep Freeze Server Enterprise.

Deep Freeze Enterprise has two editions:

• Deep Freeze Enterprise: This is a Non-Server Edition. Deep Freeze Enterprise runs on Non-
Server Operating Systems.

• Deep Freeze Server Enterprise: This is a Server Edition. Deep Freeze Server Enterprise runs 
on Server Operating Systems.

The following sections explain different ways to update Deep Freeze Enterprise (Non-Server Edition) 
and Deep Freeze Server Enterprise (Server Edition). 
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Updating Deep Freeze Enterprise (Non-Server Edition)

A Deep Freeze Enterprise deployment (6.2 and lower) consists of five components, as shown below:

As of Deep Freeze 6.3 (and higher), the Enterprise Console and Server Service Manager have been 
combined into a single component. To update the Server Service component users will need to access 
the Tools -> Network Settings menu in the Enterprise Console to configure the Server Service.

The Enterprise Console and the Server Service Manager are both able to control and administer 
workstations running prior versions of Deep Freeze, provided that they have the same Customization 
Code. Therefore, if the update process is resolving a problem in the Enterprise Console, the Configuration 
Administrator, or the Server Service Manager, then the Workstation Seeds and workstation install files 
may not require an immediate update. 

Updating Deep Freeze settings using a .rdx file will not be successful if the Enterprise 
Console and Deep Freeze Client (on the workstation) have different versions. The 
.rdx file just updates the Deep Freeze configuration. The .rdx file does not perform a 
Deep Freeze version upgrade.

Two steps are required to completely update all Deep Freeze Enterprise components:
1a. or
1b.

Automatically update all components using Update Mode.
Manually update all components.

2. Remotely update the installed workstations.

Licensing was introduced from Deep Freeze version 6.5 onwards. The License Key can be updated in 
the following ways:

• Through the Workstation Install file - The License Key is updated in the Configuration 
Administrator and a Workstation Install file is created. The License Key is now part of the 
Workstation Install file.

• Through the Enterprise Console - The License Key can be updated directly on the Enterprise 
Console  via Tools > Licensing. When the License Key is updated in the Enterprise Console, it 
is automatically updated on all connected computers. 

• Through the Deep Freeze Client - The License Key can also be updated at the workstation by 
logging into Deep Freeze and editing the License Key field.

The default port number for Deep Freeze has changed. If upgrading from version 
5 to version 6.x, the port number must be changed to 1971. Refer to page 10 for 
complete instructions for upgrading from version 5 to 6. 

Configuration Administrator

Workstation Install File

Workstation Seed Enterprise Console

Server Service Manager
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Step 1 (Option A) Update Mode (Deep Freeze Enterprise Non-
Server Edition) 

Update Mode is an advanced feature of Deep Freeze Enterprise that requires a thorough understanding 
of command line scripting.

Update Mode can be used to automatically update an existing installation set of Deep Freeze Enterprise 
to a newer version by executing a special update command. The command automatically updates any of 
the following files present in the <DRIVE>:\Program Files\Faronics\Deep Freeze 65 Enterprise\Install 
Programs folder: 

• Workstation install files
• Workstation Seed files
• .rdx Configuration Files

64-bit systems will be Program Files x86 instead of Program Files in the path. 

When updating from an older version of Deep Freeze to 6.5x and 6.61, the existing version 
files must be manually copied into the Install Programs folder in order to be successfully 
updated.

In the example below, the district office has received a new version of Deep Freeze Enterprise and can 
automatically update any existing Deep Freeze files at a remote location.

The update command does not require a password, but does require a Customization Code. The 
following command syntax must be used:

\PathToFile\df65ent.exe /update=“Customization Code” <DRIVE>:\dfupdate.log

• PathToFile must be replaced with the actual path to the installation file (df65ent.exe)
• df65ent.exe must be the actual name of the installation file
• Customization Code must be in quotes if there is a space in it
• Customization Code must match the old files’ Customization Code

The Remote Server service has to be updated manually. The update process may take a few minutes to 
complete. This process requires a third party tool to 

Update Mode does not update the existing version of Deep Freeze on workstations. 
Workstations must be updated using the Enterprise Console.

Installing Deep Freeze 6.5 will not remove or update the existing installation of the Deep 
Freeze Server Service. As only one service can be running at a given time, the older service 
will be shut down and the 6.5 service activated. To remove the older versions of the Deep 
Freeze Server Service, the existing installation of Deep Freeze should be uninstalled or 
the service entries deleted manually from the system. This can be done by running the 
installer to uninstall Deep Freeze.
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Step 1 (Option B) Manually Update all Components (Deep Freeze 
Enterprise Non-Server Edition)

Updating the Configuration Administrator and Enterprise Console

Any update to a Deep Freeze installation begins with the Configuration Administrator. Complete the 
following steps to update the Configuration Administrator:

1. Copy existing install files to a safe location for backup and archival purposes. By default, 
install files are located in the following directory:

(for 6.5 and higher) <DRIVE>:\Program Files\Faronics\Deep Freeze 65 Enterprise\Install 
Programs 

(for 6.4 and lower until 5.x) <DRIVE>:\Program Files\Faronics\Deep Freeze 6 Enterprise\
Install Programs

(for 5.x) <DRIVE>:\Program Files\Faronics\Deep Freeze 6 Enterprise\DF5 Install Programs

Any install files in this directory should be copied to a new location indicating the version 
number of the software. These install files should only be stored as a record of the configuration 
information that they contain and should not be installed in a production environment once 
the update is complete.

2. Uninstall the existing Configuration Administrator from the administrator computer via 
Start > Control Panel > Add or Remove Programs 

3. Select Deep Freeze Administrator - Enterprise (for Deep Freeze 5.x) or Deep Freeze 6 - Enterprise 
(for Deep Freeze 6.x) and click Change/Remove. 

Follow the steps presented and the Configuration Administrator is uninstalled from the 
computer.
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Installing the New Configuration Administrator and  Enterprise Console

Complete the following steps to install a new version of the Configuration Administrator on the 
administrator computer.

1. Double-click the file DF65Ent.exe to begin the installation process.

2. Follow the steps presented. Read and accept the license agreement. 

3. Enter the License Key in the License Key field. 

4. Click Install and the Configuration Administrator and Enterprise Console are installed on 
the computer

5. Once installation is completed, the workstation will prompt for the end user to enter a 
Customization Code. Enter the same Customization Code used for the previously installed 
copy of Deep Freeze. 

Clicking OK will display a confirmation of the Customization Code assigned in plain text 
and will provide an option to print for future reference.  
If the Customization Code is not entered correctly it can be re-entered using the DFInit.exe 
application located in: 
(for 6.5 and higher) <DRIVE>:\Program Files\Faronics\Deep Freeze 65 Enterprise\Install 
Programs 
However, none of the previously installed workstations will be controllable until the 
Customization Code is correct.

The Customization Code must be recorded and guarded with care. Faronics is 
unable to recover a lost or forgotten Customization Code!

Once a new Customization Code is assigned, the Configuration Administrator will 
no longer work with previously configured installations. To work with previous 
installations, use the DFInit.exe program to reset the Customization Code back to 
its original settings.
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 Updating Existing Workstation Install Files and Workstation Seeds

Complete the following steps to update new Workstation Install Programs or new Workstation Seeds 
using the Configuration Administrator. 

1. Open previously created files by clicking File > Open.

Select a file from the standard Open dialog box that appears. Click Open. 

2. Click Create > Create Workstation Install Program or Create > Create Workstation Seed.

3. Click Save to save the Workstation Install Program or Workstation Seed at a predefined 
location. Clicking Save As will create a .rdx file.

Updating the Server Service Manager

This is applicable only to Deep Freeze versions lower than 6.3.

To update a workstation running the Server Service, administrators will need to uninstall the server 
service for older versions of Deep Freeze. Thereafter, administrators can either install a full copy of the 
Configuration Administrator, and the Enterprise Console. Or, copy the DFConsole.exe application to 
the workstation or server running the server service and activate the console on the workstation being 
updated.
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Step 2: Remotely Updating the Installed Workstations (Deep 
Freeze Enterprise Non-Server Edition)

To update workstations running Deep Freeze 6.3 or higher, complete the following steps: 

1. Open the Configuration Administrator. 

2. Click Create > Create Workstation Install Program.

3. Save the Workstation Install Program on the computer as Update Only.

5. Open the Enterprise Console. Right-click on one or more workstation(s) and select Update 
icon on the toolbar or Update Deep Freeze in the context menu.

6. Browse and select the Workstation Install File Update Only.exe and click OK. 

7. Deep Freeze is remotely updated on all the selected workstations. The workstations are 
rebooted up to three times.
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Updating Deep Freeze Enterprise Version 5.x, 6.0, 6.1, 6.2 to 6.6 
(Non-Server Edition)

The first step to update to version 6.6 is to install the Deep Freeze Configuration Administrator; this 
creates the file directories where all related programs are subsequently saved to as a default.

The version 6.6 of the Configuration Administrator installs in a different directory than version 5.x. 
If Update Mode is being used as outlined in this document, care must be taken to manually copy any 
existing Workstation Install Programs, Workstation Seeds, and Enterprise Consoles into the directory 
where the version 6.6 Configuration Administrator will be installed.

By default, version 5.x files are in:
<DRIVE>:\Program Files\Faronics\Deep Freeze Enterprise\DF5 Install Programs

Version 6.x files are in:
(for 6.5 and higher) <DRIVE>:\Program Files\Faronics\Deep Freeze 65 Enterprise\Install 
Programs 

(for 6.4 and lower) <DRIVE>:\Program Files\Faronics\Deep Freeze 6 Enterprise\Install 
Programs

Change Port Number

The default port number for Deep Freeze has changed from port 1971 to port 7725 from version 6.0. If 
the change in the port number is not accounted for, version 5.x workstations will not be visible in the 
updated version 6.x Enterprise Console. 

If the former default port number of 1971 is preferred, ensure that the Workstation Installation Files 
are all created with port number 1971 (entered in the Advanced Options tab of the Configuration 
Administrator). The Enterprise Console must be configured to listen on port the same port number 
via Tools > Network Configuration.

Upgrading from Deep Freeze 5.x to 6.6x will not change the port number unless the 
port number was changed manually.

The change in Port Number between version 5.x and 6.x can be handled in two ways:

1. Continue to use the former default port number (1971) to administer your Deep Freeze 
workstations. Ensure that the Enterprise Console listens on Port number 1971 via Tools > 
Network Configuration. Note that other applications may use this port and continuing to use 
port 1971 may cause issues in the future. 

2. Change all workstations to the new port number (7725). Configure the port number in the 
Configuration Administrator (in the Advanced Options tab) and the Enterprise console via  
Tools > Network Configuration.

To update workstations running Deep Freeze 5.x, 6.0, 6.1, and 6.2 an update process through the 
Enterprise Console can be performed on the workstations by rebooting the workstations Thawed, 
uninstalling Deep Freeze, leaving the Workstation Seed, and the performing a Target Install of a new 
workstation installation file on the selected workstations. 

The new Workstation Installation Program must have all the required Deep Freeze 
settings configured before the update procedure. 
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Updating Deep Freeze Locally on a Workstation

Complete the following steps to update Deep Freeze Locally on a workstation: 

1. Open the Configuration Administrator. 

2. Configure the settings as required.

3. Click Create > Create Workstation Install Program.

4. Save the Workstation Install Program to a shared folder on the network that can be accessed 
from the workstation to be updated. Alternatively, save it to a removable storage device that 
can be moved to a workstation 

5. Reboot the workstation Thawed. 

6. Deep Freeze can only be uninstalled locally by running the DFWKS.exe. Double-click the 
DFWKS.exe and follow the steps presented on the screen to uninstall it on the workstation. 
The workstation will reboot after Deep Freeze is uninstalled. 

7. Double-click the Workstation Install File again and follow the steps presented on the screen 
to install it on the workstation. The workstation will reboot after it is installed. 

In order to maintain communication with the workstations when updating a component 
to a new version, it is essential that the Network settings of the new Workstation Install 
Program or Workstation Seed matches those of the old one.
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Updating Deep Freeze Server Enterprise (Server Edition)

If you are using an older version of Deep Freeze Server Enterprise (for example, 6.3), you must uninstall 
the older version before installing the newer version. 

• Uninstall the older version from Start > Control Panel > Add or Remove Programs and install 
the new version using DFEntServ.exe if you do not want to preserve the settings (Ports, 
Scheduled Tasks and Groups). 

• Use the Update Script provided by Faronics to retain the settings (Ports, Scheduled Tasks and 
Groups) and install the new version manually.

Installing Deep Freeze Server Enterprise 6.62 on a computer that has Deep Freeze 
Server Enterprise 6.3 does not update the computer with the new version. Installing 
Deep Freeze Server Enterprise 6.62 over Deep Freeze Server Enterprise 6.3 will result 
in two versions on the same computer. To update Deep Freeze Server Enterprise, 
uninstall Deep Freeze Server Enterprise 6.3 and install Deep Freeze Server Enterprise 
6.62. Alternatively, you can run the script provided by Faronics and install Deep Freeze 
Sever Enterprise 6.62 to preserve settings for Ports, Scheduled Tasks and Groups.

Deep Freeze Server Enterprise Console and Deep Freeze Server Configuration 
Administrator can be upgraded to a newer version by running the installer for the 
newer version. However, this feature is applicable only if you are currently using Deep 
Freeze Server Enterprise 6.62 or higher. 

Once Deep Freeze Server Enterprise has been updated on the console computer, you can update the 
workstations in one of the following ways:

1. From the Deep Freeze Server Enterprise Console. For more information, refer to Remotely 
Updating Installed Workstations. 

2. Manually on the workstation by creating a Workstation Install Program and installing 
on each workstation. For more information, refer to Updating Deep Freeze Locally on a 
Workstation. 
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Update Script for Deep Freeze Server Enterprise Console

Download DSE_UpdateScript.vbs file from http://www.faronics.com/Faronics/Documents/DSE_
UpdateScript.zip.  Steps to run the update script is explained in the next section.

Download the update script directly from the link provided above. The contents of the 
update script displayed below is just for information. Do not use the contents of the 
script show below for updating Deep Freeze Server Enterprise. 

’——————-SCRIPT START——————————— 

Set Shell= CreateObject(“WScript.Shell”)

Set FSO  = CreateObject(“scripting.FileSystemObject”)

TmpFolder= Shell.ExpandEnvironmentStrings(“%temp%”)

key32bit = “HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Deep Freeze 
Server Enterprise\UninstallString”

key64bit = “HKLM\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\
Deep Freeze Server Enterprise\UninstallString”

WinTitle = “Deep Freeze Server 6.3 Console uninstall script”

if CStr(CheckRegKey(key32bit)) then

  InstallPath = Shell.RegRead (key32bit)

  RemoteAdminKey=”HKEY_LOCAL_MACHINE\SOFTWARE\Faronics\
DeepFreezeRemoteAdministrator”

  else if CStr(CheckRegKey(key64bit)) then

       InstallPath = Shell.RegRead (key64bit)

	    RemoteAdminKey=”HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Faronics\
DeepFreezeRemoteAdministrator”

        else 

	 BtnCode = Shell.Popup(“Deep Freeze Server 6.3 Console is not installed on this 
machine.”, 0, WinTitle, 16)

         wscript.quit

       end if  

end if   

InstallPathAdmin=Replace(InstallPath,” /uninstall”,””)

InstallPathServ = Replace(InstallPath,”Deep Freeze Server Enterprise\dfadmin6.exe /
uninstall”, “Deep Freeze Enterprise Server”)

InstallPath = Replace(InstallPath,”\Deep Freeze Server Enterprise\dfadmin6.exe /
uninstall”, “”)

if FSO.FolderExists(InstallPathServ) then 

   FSO.CopyFolder InstallPathServ, TmpFolder & “\Deep Freeze Enterprise Server”

   Shell.Run “Regedit /e “ & TmpFolder & “\_$dfreg.reg “ & RemoteAdminKey, 2, true

	   else 

	     BtnCode = Shell.Popup(“Unable to locate “”Deep Freeze Enterprise Server”” 
folder”, 0, WinTitle, 16)

        wscript.quit

end if	
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 Shell.Run “””” & InstallPathAdmin & “””” & “ /uninstall”, 2, true

if FSO.FolderExists(InstallPath) AND FSO.FolderExists(TmpFolder & “\Deep Freeze 
Enterprise Server”) then 

  if NOT FSO.FolderExists(InstallPathServ) then FSO.CreateFolder(InstallPathServ)

  FSO.CopyFile TmpFolder & “\Deep Freeze Enterprise Server\*.DF5”, InstallPathServ 
& “\”, True 

  FSO.CopyFile TmpFolder & “\Deep Freeze Enterprise Server\*.xml”, InstallPathServ 
& “\”, True

  Shell.Run “Regedit /c /s “ & TmpFolder & “\_$dfreg.reg”, 2, true

  if NOT FSO.FileExists(InstallPath & “\Deep Freeze Server Enterprise\DFInit6.exe”) 
then BtnCode = Shell.Popup(“Deep Freeze Console configuration has been successfuly 
restored.”, 0, WinTitle, 64)

end if

if FSO.FolderExists(TmpFolder & “\Deep Freeze Enterprise Server”) then FSO.
DeleteFolder(TmpFolder & “\Deep Freeze Enterprise Server”)

if FSO.FileExists(TmpFolder & “\_$dfreg.reg”) then FSO.DeleteFile(TmpFolder & 
“\_$dfreg.reg”)

Function CheckRegKey(sKey)

 On Error Resume next

 Shell.RegRead sKey

 CheckRegKey = (Err.Number = 0)

 On Error Goto 0

End function

’——————-SCRIPT END——————-
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Running the Update Script for Deep Freeze Server Enterprise Console

1. Launch the Command Prompt. For Windows Vista or Windows 7, use the Run as 
Administrator option. 

2. Run DSE_UpdateScript.vbs file created in the previous section from the Command Prompt. 
The script uninstalls the older version of Deep Freeze Server Enterprise Console and Deep 
Freeze Server Configuration Administrator. The update script also copies the settings from 
the older version of Deep Freeze Server Enterprise Console. 

3. Run DFEntServ.exe to install the new version of Deep Freeze Server Enterprise. The newer 
version of Deep Freeze Server Enterprise Console will now display the settings from the 
older version. 
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